UiPath Robot Guide

Software Requirements

Supported Versions

Operating System

.NET Framework

  • minimum: 4.5.2

(!) Robots can be installed in Citrix environments if they meet the following requirements:

  • They are licensed through Orchestrator and not locally;
  • The machine name does not change every time it is spawned.

Please note that if you license your Robot locally, in the Citrix environment, you have to do it every time you start the Citrix machine.

Important!

In rare cases, the Robot stops working and throws an error which states that it does not have access to a temporary file. This is caused by a Windows 7 or Windows Server 2008 R2 issue and can be solved by installing this hotfix. Apply this hotfix only to systems that are experiencing the problem described.


Software Requirements